Cant play video fullscreen when hosted on BitChute.

Best Gore Forums Best Gore Website Website Support Cant play video fullscreen when hosted on BitChute.

This topic contains 7 replies, has 4 voices, and was last updated by  Vincit Omnia Veritas 4 weeks ago.

  • Author
  • #110152


    Hello dear Gorians,

    Just recently videos are being hosted via BitChute. and now i cant get my gore to play in full screen mode.
    There is not even a menu for me to choose any playback size?!

    Why is this?

  • #110220


    Yes, I have the same problem. I’m viewing on a desktop pc separate flat screen monitor. I’m straining my eyes to see videos because the viewing area is tiny. Really difficult to see detail.

  • #110226

    Right click on the video and select “Full Screen”

  • #110232


    Hi Mark,
    I tried that, but it does not give me the option to do so…
    I did came across this topic:

    Maybe it is a setting that needs to be activated from your end?


  • #110236

    I’m using a different player, which doesn’t have the button activated when the player is embedded. I spoke with the developer to include the button in an update. Your browser should support the option to view the video in the full screen mode, as this is a computer capability, not the website’s. If your browser doesn’t provide the option to view videos in full screen, switch over to Tor (which everyone should do for many other reasons):

  • #110257


    bitchute is below par

  • #110267


    I tried right clicking on the video and there isn’t a full screen option. All I get is Play, Mute, Save Videos, Copy Video URL, Play Speed, Inspect Element.

    I don’t want the aggro of downloading and having to use another browser. If the new player doesn’t work on Internet Explorer (version 11 for me) – probably the most widely used browser, it can’t be up to much. Sorry to say it looks like a retrograde step.

    • #110309

      Internet Explorer usage is only around 5%. Though it’s pretty sad that so many people are tricked into using Google Chrome.

You must be logged in to reply to this topic.